RE: *#@!sticking base molds HELP!

<< Previous Message | Next Message >>
From:Brown Alex <Alex.Brown@aaaht.scot.nhs.uk>
To:HistoNet <Histonet@pathology.swmed.edu>
Reply-To:
Content-Type:text/plain; charset="iso-8859-1"

Hi Kelly,
	Sorry, no idea. Could they be too clean ?? ( seems unlikely though )
. When we are finished with the moulds we put them back in the embedding
centre to warm up and then just wipe them with a clean cloth. Never have a
problem with 'sticking'. When the blocks are cold enough they just pop out (
so to speak :) )
Alex Brown
Crosshouse Hospital
Kilmarnock, Scotland.
 ----------
From: Kelly Pruitt
To: histonet@pathology.swmed.edu
Subject: *#@!sticking base molds  HELP!
Date: Wednesday, April 26, 2000 3:32PM

Hi Histoland!  I need help.

What can I do to keep my base molds from sticking to my blocks?  We clean
them in xylene and then soap and water.  We air dry them.  We treat/spray
them while they are clean with Histo Prep after they have air dried.  I give
them a good coating when I use the Histo Prep.  The larger molds are usually
good for one use.  On the biopsy molds, they stick every time.  It doesn't
matter what I do.

We have bought some of the plastic disposable molds, but they slow embedding
down for me.

Does anyone have a clue what the problem is?  Does anyone know what I can
do?  Please help!

Kelly S. Pruitt, HT (ASCP)
Texas A&M University
College of Veterinary Medicine
Dept. of Veterinary Anatomy & Public Health
Histology Laboratory
College Station, Texas 77868-4458
kpruitt@cvm.tamu.edu
phone: 409-845-3177
fax: 409-847-8981




<< Previous Message | Next Message >>